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1.0 Introduction to BrowseReporter  
 
BrowseReporter is an easy to use reporting tool, designed to allow department managers, team 
leaders, teachers and lecturers to monitor user Internet browsing activity. 
 
BrowseReporter provides the facility to generate reports and graphs at both the computer and user 
level.  In depth information of the sites visited and the time spent at these sites are presented.  
Detailed reports, summary level reports and graphs can be generated. 
 
In addition, to tracking Internet activity, BrowseReporter also includes bandwidth monitoring and 
remote screen capture functions. 
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1.1 CurrentWare Components 
 
There are four primary components in the CurrentWare Console 
 

CurrentWare Server 

This component includes a server Service and database. It houses all the data for the configuration 

and settings. The CurrentWare Server is the central hub for the CurrentWare Consoles and the 

CurrentWare Clients to connect to. A Firebird database is used for the data storage. 

 

CurrentWare Console  

This component is the management console that the administrator uses to control the functionalities 
of the CurrentWare Solutions. The administrator will be able to see the connection status of their 
CurrentWare Clients within the CurrentWare Console. 
 
Multiple consoles can be installed on the same network. Multiple authentications can be assigned to 
different users to allow or restrict the full functionality of the console.  
 

Note: the CurrentWare Server and the Console components are commonly installed on the same 

computer. Additional CurrentWare Consoles may be installed on other administrators‟ computers. 

 

CurrentWare Solutions  

This component contains different functionalities based on the solution that you are installing. After 

the installation of a CurrentWare solution, the solution‟s functions will be embedded on the right 

hand side of the CurrentWare Console. 

 BrowseControl: Internet Management 

 BrowseReporter: Internet Tracking and Reporting 

 enPowerManager: Power Management 

 AccessPatrol: Endpoint Security Tool 

 

CurrentWare Client  
This component is to be installed on all computers that need to be managed by the CurrentWare 

Console. The CurrentWare Clients establish communication to the CurrentWare Server. The client is 

password protected and runs in stealth mode. 
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1.2 System Requirements 
 

Hardware Requirement 

All components of the CurrentWare Console are supported on desktop computers and server 
computers with the following specifications.  
 

 Processor: Any CPU running faster than Pentium II. 

 Memory: At least 128MB of RAM 

 Disk Space: At least 100MB of disk space 

 

Software Requirement 

All components of the CurrentWare Console are compatible with the following Operating Systems 
 

 Windows XP Professional* 

 Windows Vista Professional* 

 Windows 7 Professional and Ultimate* 

 Windows Server 2003* and 2008** 

 

* Support for 32-bit and 64-bit computers. 

** Support Windows Terminal Server  
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1.3 Installing the CurrentWare Server, Console and 
Solutions  
 
Follow the instructions below to install the CurrentWare Server, Console and Solutions on your 
network.  

Before you begin your installation: 

 Installation of all components must be done with an admin user account. 

 The Server and Console components may be installed on the same computer. 
 
 

1. Download the Setup Files 

Download the CurrentWare setup files from our website: 

http://www.CurrentWare.com. Remember to also download the setup file for 

the CurrentWare solutions (BrowseControl, BrowseReporter, 

enPowerManager, and AccessPatrol) that you want to install. 

 

2. Select a Computer to install the CurrentWare Server and Console 

 

3. Install the CurrentWare Server and Console 

1. Unzip the setup file that you downloaded from our website and run the 
currentware.exe  to initiate the CurrentWare Console Installation Wizard.  

 

2. Proceed to accept the License Agreement. 

 

3. Put in your User Information  (Full Name and Organization name) and select 
the software usage for “Anyone who uses this computer” or “Only for me”  

 

4. Now, select the CurrentWare Components  that you want to install. For first 
time installation, click next. The install wizard will automat ically select the 
CurrentWare Console and Server to be installed on your computer.  

 

5. Type in the computer name (or IP address) of your CurrentWare Server. For 
first time installation, click next. The install wizard will automatically type in 
your Computer name.   

 

http://www.currentware.com/
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6. The Installer will now proceed to install the CurrentWare Server and Console 
on your computer.  

 

4. Install the CurrentWare Solutions 

Once your CurrentWare Server and Console are installed, you can proceed to 

install the CurrentWare Solutions by running the appropriate setup file below 

(You have to download the CurrentWare Solutions setup file from our 

website): 

 

 BrowseControl: run BrowseControl.msi 

 BrowseReporter: run BrowseReporter.msi 

 enPowerManager: run enPowerManager.msi 

 AccessPatrol: run AccessPatrol.msi 
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1.4 Installing the CurrentWare Clients  
 
Follow the instructions below to install the CurrentWare clients on the computers you want to 
manage. After a successful installation of the CurrentWare Clients, they will connect to your 
CurrentWare Server and automatically show up on your CurrentWare Console.   

Before you begin your installation: 

 Installation of all components must be done with an admin user account. 

 To successfully deploy the CurrentWare Client using the Remote Client Install utility, 
please temporarily disable the Windows Firewall on the client computers and disable 
Window‟s Simple File Sharing.  

 
There are four ways to deploy the CurrentWare Clients to your workstations.  

 

1. Local CurrentWare Client Install: run the cwClient.msi file on all the 

computers you want to manage.  

2. Remote Client Install: use the built-in Remote Client Install tool on the 

CurrentWare Console to push the CurrentWare Client install to the 

computers.  

3. Deploy the CurrentWare Client by Command Line: create a batch file 

that will install the CurrentWare Client. Run the batch file through Active 

Directory or Login Script.  

4. Deploy the CurrentWare Client with a Third-Party Software Delivery 

Tools: use third-party software to deploy the cwClient.msi file.  

 

1.4.1 Local CurrentWare Client Install 
  
This is the most standard method of installing the CurrentWare Client. Run the cwClient.msi file on 
each computer you want to manage.  
 
The cwClient.msi file can be found on the computer that you have installed the CurrentWare Server. 
This set up file is stored under: 
 
 CurrentWare Client Setup File: 

C:\Program Files\CurrentWare\cwClient\cwClient.msi 

 
When you run the cwClient.msi on your managed computers, you will need to fill in the following 
information.  
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1. Computer Name or IP Address of the CurrentWare Server 

Put in the Computer Name or IP address of the CurrentWare Server that 

you want the client to connect to. Ensure that the managed workstations 

can establish connections to the CurrentWare Server.  

 

2. CurrentWare Client Password (Optional) 

The CurrentWare Client password is used to configure the CurrentWare 

Client settings. If you do not put in a custom CurrentWare Client password, 

then the default password is “Admin” (without the quote; case sensitive).  

 

Upon the completion of your CurrentWare Client installation, it will automatically connect to your 

CurrentWare Console.  

 

1.4.2 Remote Client Install 

Before you begin your installation:  

 On computers running Windows Vista, Windows 7 and Windows 2008, please disable UAC 
(User Account Control) before running the Remote Client Install. 

 
CurrentWare Clients can be remotely installed from the Console. The remote installer can be found 
on the console under the menu Install > Client > Remote Client Install.   
 

1. Browse for the path of the CurrentWare Client setup file, cwClient.msi, on your 
computer. By default this file is located in the following folder on the server 
computer: 

 

C:\Program Files\CurrentWare\cwClient\cwClient.msi 

 

2. Select the option to enable or disable reboot after the installation (the 
recommended option is to enable reboot).  

3. Select the appropriate Install option: Fresh Install or Upgrade. 

4. Enter the Computer name or IP address  of the CurrentWare Server.  

5. (Optional): Change the CurrentWare Client password . 

6. Select the computers you want to install the CurrentWare Client on:  
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a. You can enter the IP address manually, or  

b. Click on the Search button to allow CurrentWare to look for the 
computers on your network, or  

c. Import from a text file that contains a list of your computers‟ names of IP 
addresses. 

7. Enter the username and password of an account that has administrative rights 
to the computers you are installing to  

a. If you are a domain admin, put in the username in the format of 
Domain\Administrator 

8. The CurrentWare Client will now be deployed to the designated computers.  

 

 

The First screen of the Remote Client Install Window 

 

1.4.3 Deploy CurrentWare Client by Command Line 
 
The CurrentWare client file can be deployed through a single command line. Below is a list of 
switches you can along with the command line to deploy the CurrentWare client with the 
configurations of your choice.  
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e:\cwClient.msi ALLUSERS=1 USERPARAMS="-p Admin -ds 

192.168.1.100 -rp test -sp test" /qn /l e:\install.log 

  
Switches: 
 
-p  Required parameter (password is Admin) 
-ds CurrentWare Server IP address or Computer name 
-rp New Password (Optional) 
-sp Confirm Password (Optional) 
/qn Quiet Install 
/l Create a log file during the install. Specify the location and name of the log file. 

 
In the above example, the network drive is assigned with the letter e:\. The CurrentWare 
Client set up file is stored on the network drive and the install log file will be created on the 
network drive after the installation.  

 

1.4.4 Deploy CurrentWare Client with a Third-Party Software Delivery 
Tool 
 
The CurrentWare Client is packaged as a MSI file. You can use your company‟s system deployment 
tools to deploy the CurrentWare client to your workstations.  
 

Deploy by customizing the cwClient.MSI file 

You can take the existing cwClient.msi file and customize it with the proper CurrentWare Server 
Computer name and other parameters before you deploy the file.  
 
Use a MSI editor (for example, the Orca MSI editor) and modify the following table within the 
cwClient.MSI file: 
 

 
Table   Property   Value 

Property   USERPARAMS  "-p Admin -ds 192.168.1.100" 

 

Change the IP address in the value field to the IP address of your CurrentWare Server.   



 

 

www.CurrentWare.com  14 
 

1.5 Upgrading the CurrentWare Clients  
 
There are two ways to upgrade the CurrentWare clients in version 4 – Automatic upgrade or Manual 

upgrade.  

1.5.1 Automatic Upgrade of the CurrentWare Clients 
 
The client upgrade process can be automated when you upgrade any version of the CurrentWare 
client to the latest version.  
 

1. On the CurrentWare Console, go to Install > Client > Remote Install  

2. Click on the Upgrade button 

3. Click on the “Automatically upgrade clients from version 4.0.0.0 and above”  
checkbox and the CurrentWare Server will push the update to the cl ients.  

 

 

The Client upgrade is automatic when this option is enabled.  

1.5.1 Manual Upgrade of the CurrentWare Clients 
 
The client upgrade method can be done manually by running the cwClient.msi file on each computer 

that has CurrentWare v4 client installed.  
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1.6 Terminal Server Setup 
 
The CurrentWare Console is compatible with Windows Terminal Server. The terminal server 

installation is the same as a normal CurrentWare Console installation.  

The following Solutions are compatible with Terminal Server: 

 BrowseControl 

 BrowseReporter 

 

1.61 BrowseControl and Terminal Server 
 
In order to view the users on your Terminal Server, you must change your CurrentWare Console 

from PC mode to User mode.  

On the CurrentWare Console, expand the BrowseControl tab on the right hand side. Click on the 

Mode button. Select User mode and click Apply. You are now using BrowseControl in User Mode.   

Once you are in user mode, your Terminal Server users will be listed under the User Mode tab 

automatically after they log onto the terminal server for the first time.  

 

1.62 BrowseReporter and Terminal Server 
 
BrowseReporter is automatically compatible with Terminal Server without the need of any further 

configurations.  

The Terminal Server users will be listed under the User Mode tab automatically after they log onto 

the terminal server for the first time.  
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2.0 CurrentWare Console Overview 
 
The CurrentWare Console is the manager that the administrators will use to control the managed 

workstations.  

The CurrentWare Console contains the following functions. 

 Client and Group Management 

 Redirect Clients 

 Client Settings 

 Operators 

 Import Users 

 Options 

 Log Out 

 

 

The CurrentWare Console 
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2.1 Client and Group Management 
 
In computer mode, a connected client is represented by a blue computer icon, while an unconnected 
client is represented by a grey computer icon. In user mode, an active user is represented by a 
green user icon, while an inactive user is represented by an orange user icon. For ease of 
management, the workstations and users can be organized into groups.   
 

Create a New Group 

To create a new group, from the menu, select File > Add New Group 
 
Or, right click on the computer pane in the CurrentWare console and select Add New 
Group.  

 
 

Rename a Group 

To rename a group, from the menu, select File > Rename 
 
Or, right click on the computer pane in the CurrentWare console and select Rename.  
 

 

Delete a Group 

To delete a group, from the menu, select File > Delete 
 
Or, right click on the computer pane in the CurrentWare console and select Delete.  

 

Move Computers/Users 

On the CurrentWare Console, organization of the computers, users and groups can be 
accomplished by dragging and dropping the selected computer/user into the group. To 
facilitate the organization of a large number of computers, users or groups, you can use the 
Move Computers/Users function. 
 
On the CurrentWare Console menu, select File > Move Computer/Users. The left hand 
side contains the source folder and the right hand side contains the destination folder. Select 
the computer(s) you want to move from the source folder, and then select the destination 
folder. Click on the >> button to move the computers. 
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2.2 Redirect Clients 
 
Redirect Clients is usually used when there are more than one CurrentWare Servers installed on 

your network. It is used to connect the CurrentWare Clients from another CurrentWare Server to the 

current CurrentWare server. Essentially, the redirect clients tool, transfers the CurrentWare Clients 

from one server to another. 

Scenario: I need to transfer all of my CurrentWare Clients from my old server to the new server.  
 

1. On the new CurrentWare Server, launch the CurrentWare Console and 
access the menu Tools > Redirect Clients . 

2. Enter the CurrentWare Client password. The default password is Admin  

3. Select Redirect All CurrentWare Clients. 

4. Enable the option Redirect connected Client(s)  

5. Click on OK 

6. After a brief moment, the CurrentWare Clients will start connecting to the 
new Server. 

 

 

Redirect CurrentWare Clients that are connected to one CurrentWare Server 

 to another CurrentWare Server 
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2.3 Client Settings 
 
The CurrentWare Client settings can be modified in the CurrentWare Console under Tools > Client 

Settings.  You can also right click on a group to find the Client Settings.  

Change Password 

Put in the new CurrentWare Client password to replace the existing CurrentWare Client password. 

You will need to use the CurrentWare client password if you want to change the client settings, such 

as IP address or computer name of the CurrentWare Server or the port that the client use to connect 

to the CurrentWare Server.  By default the case sensitive Client password is Admin. 

Options 

 Run at Windows Startup: toggle the option to allow the CurrentWare client service to start 

every time the workstation boots up.  

 

 Show in System Tray: toggle the option to display the CurrentWare icon in the system tray. 

When this option is enabled, the administrator can double click on the icon, put in the 

password, to access the CurrentWare Client configuration window.  

 

 Block admin users from stopping the client: toggle the option to prevent the users of the 

workstation to stop the CurrentWare Client service or end the CurrentWare Client process.  

 
 

 

CurrentWare Client Settings 
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2.4 Operators 
Operators are used in the CurrentWare Console to assign console permissions to different users. 
The Operators utility is available on the CurrentWare Console under Tools > Operators. There are 
two types of operators in CurrentWare Console: Administrator and User.  
 

 Administrator type has complete control over every computer, group and the solution‟s 
functionalities.  

 

 User type has limitations defined by the administrator. These limitations include the 
solution‟s functionalities and group accesses.  

 

Password Protect the Console 

In order to password protect the console, operator accounts need to be created. 
 
Creating an Operator: 

1. Launch the CurrentWare Console. 

2. On the menu select Tools > Operators. 

3. Click on the Add button. 

4. Fill in the name, password and description.  

5. Select a role for this operator. While the Administrator role has access to all 
the features of BrowseReporter, the User role only has the limited access to the 
solution‟s functionalities. 

6. Click OK to create a new operator.  

 
Enable Password Protected CurrentWare Console 

1. Create an operator with the step above. 

2. Check the option Enable Password Security. 

3. Log out of the CurrentWare Console.  

4. The next time you log into the CurrentWare Console, you will be prompted for a 
username and password. 
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Administrators have unlimited control. Users have limited controls 

 

NOTE: When you import users from Active Directory to the CurrentWare Console as 

operators, the operator name will be the same as the username on active directory. 
However, the passwords cannot be retrieved directly from the Microsoft Active 
Directory for security purposes. The new password for each operator is the username 
in lowercases. For example, if your Active Directory username is John, your 
CurrentWare operator password will be john.  
 

2.5 Import Users 
The Import users function will import your existing Windows users from your Active Directory domain 
into the CurrentWare Console.  
 

1. In order to import users, your CurrentWare Console must be in User Mode. Click 
on the tab called “User Mode” below the too lbar on the left hand side to activate 
User Mode.  

2. Click on Tools > Import Users  

3. Select to Import from Active Directory or from a Text File 

4. Enter the Domain administrator  credential (Domain name, user name and 
password) and click on the Import Users button.  
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5. A list of your Active Directory Users will be populated in the window.  

6. Select specific users you want to add to the CurrentWare Console or click on 
the checkbox Select All Users.  

7. Click Add Users to add the selected users to the Console.  

 

 

Import Windows Users from Active Directory 

 

2.6 Options 
 
Details of the Console port and newly connected client management are available on the 

CurrentWare Console under Tools > Options 

General 

Add new Computers to the group: define the group that a new computer will automatically be 

assigned to once it connects to the CurrentWare Server for the first time.  
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Add new Users to the group: define the group that a new user will automatically be assigned to 

once it is populated to the CurrentWare Server for the first time. 

 

 

 

Connection 

CurrentWare Server: the computer name or the IP address of the CurrentWare Server that the 
CurrentWare Console is connected to.  
 
Console Port: The port that CurrentWare Console uses to connect to the CurrentWare Server. The 
default Console port is 8990.  
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2.7 Log Out 
 
Log Out can be used to re-log into the Console with a different user name and password. This 
feature can be found under the menu File  Logout. 
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3.0 Overview of BrowseReporter Functions 
 
BrowseReporter is an Internet tracking tool that allows an administrator to review the Internet 

activities of the network users.  

An overview of the BrowseReporter functions includes: 

 Run Report 

 Request Latest Data 

 Upload Data Scheduler 

 URL Tracking Scheduler 

 URL Exclusion List 

 Email Reports 

 Export URLs 

 Delete URLs 

 Remote Screen Capture 
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4.0 Run Report 
 
The reports are the core components of BrowseReporter. The administrator can generate reports to 
view the Internet activities of his/her users.  

 

 
 

4.1 Report Profile 
 
Administrators can create different report profiles to use as shortcuts to reports and settings that 
they commonly use in BrowseReporter. A report profile will store the selection for report type, the 
computers or users selected options, idle time option and the reporting period.  
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How to create a report profile 

1. Select Run Report on the BrowseReporter menu located on the right hand side 
of the CurrentWare console. 

2. Select the Report type 

3. Select the computers or users you want to generate for your report profile  

4. Select the sorting and ordering of your report  

5. Choose the Idle Time Limit settings 

6. Choose a reporting period 

7. Click on Save Profile  

8. Give a name to the report profile and click OK 

 
The profile is now saved and can be accessed for future report generation. To retrieve the report 
profile, simply select the report profile from the Report Profile list the next time you run a report.   
 

4.2 Report Type 
 
There are many different types of reports within BrowseReporter ranging from a detailed report that 
includes all the websites that the users visited (Sites Visited) to a graph that shows the top 10 
domains that your network users are visiting. This is a list of all the Reports in BrowseReporter: 
 

 Sites Visited:  detail of web sites visited and the duration of each visit on a per  computer or 
user basis 

 

 Domains Visited:  similar to the Sites Visited report, but displays the website domain and 
duration of each visit.  
 

 Top (N) Domains by Hits:  summary of hits by popular domains visited on a per computer 
or user basis. (N) is a number that you can define in the Report options. 

 

 Top (N) Domains by Browsing Time:  summary view of a list of top domains that the 
computer or user has spent the most time on. (N) is a number that you can define in the 
Report options. 

 

 Domain Summary:  an aggregate list of domains sorted by browsing time.  
 

 Total Browsing Time:  accumulated time spent on the Internet for each computer or user.  
 

 Bandwidth Usage:  bandwidth sent or received by the computers or users with details of 
each URL.  

 

 Bandwidth Summary:  accumulated bandwidth consumption for the time period.  
 

 Graph – Hourly Browsing Time:  a graphical display of the accumulated Internet browsing 
time for users for each hour of the day.  
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 Graph – Weekly Browsing Time:  a graph that shows the accumulated Internet browsing 
time for users for each day of the week. 

 

 Graph – Top 10 Computers by Browsing Time:  a graph of the top 10 computers on your 
network that spent the most time on the Internet.  

 

 Graph – Top 10 Users by Browsing Time:  a graph of the top 10 users on your network 
that spent the most time on the Internet. 
 

 Graph – Top 10 Domains by Hits:  a graph of the top 10 domains on your network that your 
computers or users visited most frequently by hits.  
 

 Graph – Top 10 Domains by Browsing Time: a graph of the top 10 domains on your 
network that your computers or users spent the most time on. 

 

4.3 Report Options 
 
The BrowseReporter Report Options utility allows you to customize the report on the basis of 
specific criteria. 
 

4.1.1 Select Mode 
 
Select the computers or users to generate a BrowseReporter report on. You can select an individual 
computer, multiple computers and a group of computers. The same selection applies for the users. 
 

4.1.2 Options 
 
The BrowseReporter report options allow you to select the sorting and ordering of the report. You 
can sort by URL, Browsing Date, Browsing Time, Domains, Hits, Date, Bandwidth Sent and 
Bandwidth Received.  
 
Reports can be sorted by ascending or descending order. 
 

4.1.3 Idle Time Limit 
 
The Idle time limit filters out web sessions that are perceived to be inactive or idle from the final 
report. This function is optional and the time limit value is defined by the administrator. The URLs 
with a web session period longer than the idle time limit will not be displayed in the reports. 
 
 

Set idle time limit  

When enabled, the BrowseReporter will look for all browsing sessions that are longer than the idle 
time limit value and exclude it from the report.  
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Display idle time URLs in reports 

When enabled along with the “Set idle time limit” option, the BrowseReporter will look for all 

browsing sessions that are longer than the idle time limit value and add a red asterisk indicator * 
before the entry in the report.  
 

4.1.4 Reporting Period 
 
Select the time and date period for the report. The reporting period options are as follow: 
 

 All 

 Today 

 Yesterday 

 Last 7 Days 

 Last Month 

 Custom Range: day and time range.   

 

Request Latest Data 

A button for requesting latest data is also located on the Run Report Window for easy access.  
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5.0 Request Latest Data 
 
The Internet data tracked by BrowseReporter is initially stored locally on the CurrentWare Client 
computer. This data must be uploaded to the CurrentWare Server before the administrator can 
generate a report.  
 
You can manually request the latest data from the CurrentWare Client workstation when the 
CurrentWare Client is connected to the CurrentWare Server.  
 

How to request the latest data from a computer 

1. Select the desired computer or group folder  

2. Click on Request Latest Data under the BrowseReporter tab 

3. Select the computer that you have selected in step 1 

4. A window will appear with the upload progress  

5. Click OK when the upload is finished. 

 
You can also request the latest data automatically by setting up an upload data scheduler. See the 
next section called Upload Data Scheduler for more details.   
 
 
 

 

Request latest data to update the data in your BrowseReporter database 
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6.0 Upload Data Scheduler 
 
Schedules can be created to automatically upload data from the Client systems on a daily, weekly, 
or monthly basis. The Upload Scheduler is group specific.  
 
To access the Upload Scheduler, under the BrowseReporter tab on the right hand side of the 
CurrentWare Console, click on Upload Data Scheduler. 
 

How to create an upload data schedule 

1. Click on Upload Data Scheduler  under the BrowseReporter tab 

2. Click on the Add button 

3. Select your schedule (Daily or Weekly).  

4. For Daily, pick the time and click on the add schedule button  

5. For Weekly, pick the time and the week days, then click on the add schedule 
button 

6. Click Enable Scheduler 

7. Click Apply 

8. BrowseReporter will now automatically upload the data at the scheduled time.  

 

 

The Upload Scheduler will automatically upload data to the CurrentWare Server at the scheduled time. 
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7.0 URL Tracking Scheduler 
 
Collecting URL information at all times may be unnecessary.  For example, managers may only be 
interested to track browsing activity during business hours.   
 
Through the URL Tracking Scheduler, you can schedule the date and time ranges for collecting the 
Internet browsing activity.   Outside of these schedules, no browsing data will be collected.  This also 
helps to maintain the database size.  Below is an example of how to use the URL Tracking 
Scheduler.  
 

Scenario: Track URLs only during work hours. 

Predefined work hours: 9:00 AM to 5:00 PM. BrowseReporter will track Internet activities only 
during the work hours.  
 

1. Launch the URL Tacking Scheduler by selecting clicking on URL Tracking 
Scheduler under the BrowseReporter tab on the right hand side of the 
CurrentWare Console.  

2. Click on the Add button.  

3. Select Daily 

4. Set the start time as 9:00 AM and the stop time as 5:00 PM.  

5. Click on Add Schedule 

6. Click on Enable Scheduler 

7. Click on Apply 

8. BrowseReporter will now only track the Internet activities of the computers or users during 
the scheduled time.  

 
 

 

The URL Tracking Scheduler will only track Internet activitiy during the specified time range 
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8.0 URL Exclusion List 
 
When monitoring the browsing activity of users, it may be necessary to purge the tracking of 
authorized URLs.  Adding “authorized” URLs to the Exclusion List eliminates them from being 
tracked by BrowseReporter.  
  
To access the URL Exclusion List, under the BrowseReporter tab on the right hand side of the 
CurrentWare Console, click on URL Exclusion List. 
 

 
 

 

Show Excluded URLs in Reports:  

By enabling this checkbox, all URLs defined under the exclusion list will be listed in the reports 
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Upload Excluded URLs from the clients:  

When this option is disabled, URLs under the Excluded List will not be uploaded to the central 
database.  Removing irrelevant data will enhance the performance of the server database.  This 
option will permanently erase the excluded URLs on the client‟s local database, before any data is 
uploaded to the server.  

 

Delete Excluded URL History 

When you click on this button, BrowseReporter will delete all the Internet activities that contain the 
entries listed on your Excluded URLs list.  

 

Import and Export 

A copy of the Excluded URL list can be saved by exporting it to a text file. You can also import a text 
file that contains a list of URLs you want to exclude into the Excluded URL list.  
 
In the text file, each entry must be separated by a line break.  
 

9.0 Email Reports 
 
Through the Email Reports feature, the BrowseReporter reports can automatically be generated and 
emailed to the administrator periodically.  This eliminates having to rely on the manual process of 
creating reports.   
 
To access Email Reports, under the BrowseReporter tab, click on Email Reports.  
 
 

How to create a schedule for e-mail reports: 

Note: You must have your email settings configured and a report profile created before creating an 
email report schedule.  
 

1. Under the BrowseReporter tab on the right hand side of the console, select 
Email Reports.  

2. Click on the Create Schedule button 

3. Define the email address of the recipient of the reports.  

4. Select a Report profile to generate a report of your choice.   A report profile is 
created in the Report Options menu item.  

5. Define the schedule type (daily or weekly)  of the email report.  

6. Define the delivery time of the email report.  

7. The Internet report will be sent in a PDF format.  
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9.1 Email Settings 
 
Under the Email Settings tab, enter the email configuration that is required to successfully send the 
reports to the administrator.  
 

How to Configure your Email Settings 

1. Enter the appropriate email Information, including the name, email address 
and the password for your email address.  

2. Define the outgoing mail server  that your email account uses to send email. 
The default SMTP port that BrowseReporter uses to send email is port 25.  

3. Enable mail server authentication  if your email server requires the 
authentication.  

4. You can also use web email services, such as Gmail/ Hotmail/ Yahoo mail, to 
generate email notifications. These web email services usual ly require mail 
server authentication.  

5. To test the validity of the email account information, c lick on the Test Email 
Account button to ensure that the reports wil l be emailed successfully.   

6. Click on the Apply button 
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10.0 Export URLs 
 
The Export URLs feature allows the administrator to export a list of domains from the 
BrowseReporter reports directly to the BrowseControl‟s URL filter list.  
 
BrowseControl is a separate CurrentWare solution that controls the Internet access of your users. By 
integrating the URLs from BrowseReporter, administrators will be able to use the tracked URLs to 
control the Internet access of the users.  
 

 

Export the URL directly to the BrowseControl URL filter 
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11.0 Delete URLs 
 
The administrator can delete specific URLs from the BrowseReporter database.  
 
To Delete URLs from the BrowseReporter database: 
 

1. From the BrowseReporter tab, click on Delete URLs 

2. Select the computers or users that you want to delete the data from.  

3. Specify the time period to delete the data from.  

 
 

 

Define the BrowseReporter data that you want to delete 
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12.0 Remote Screen Capture 
 
Track employee/student activity by capturing screenshots of their PCs on regular intervals.  Identify 
users who are spending excessive amounts of company/school time on unauthorized sites, chats, 
games etc.   
 
 

How to use Remote Screen Capture 

1. Select the computer on the left hand panel of the CurrentWare console  

2. Under the BrowseReporter tab, click on the remote screen capture  button 

3. A window will now appear to display the screen of the remote computer  

 

The ideal display resolution for remote screen capture is 1024 by 768. If the remote computer has a 
higher resolution, then the remote screen capture may not display properly. 
 

Note:  ensure that port 1024 is open on the client system, to allow for screen capturing.   
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13.0 BrowseReporter Client Settings 
 
The BrowseReporter Client Settings allow the administrator to enable the BrowseReporter Client 
warning message.  
 
The warning message will appear to the users when they log on to their computers.   
 
 

 

BrowseReporter Client Settings 
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14.0 CurrentWare Server Manager 
 
The CurrentWare Server Manager is used to manage the administrative tasks of the CurrentWare 

Server.  To access the Server Manager, click on the Start Menu > Programs > CurrentWare > 

CurrentWare Server Manager 

14.1 Changing the CurrentWare Client and Console Port 
 
Changes to the Client and Console ports may be required to establish the connections between the 

CurrentWare server, clients and consoles. For example, if you are using a program that is already 

utilizing the ports that CurrentWare uses, then you will need to change the ports. Otherwise, please 

do not modify the Client and Console ports.  

The default client port is 8991 and the default console port is 8990. 

 

 

CurrentWare Server Manager 
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14.2 Stopping the CurrentWare Server Service 
To stop the CurrentWare Server, under the Service tab, click on the button “Stop CurrentWare 

Server” 

 

 

14.3 Compress the CurrentWare Database 
It is recommended that database compression be performed on a regular basis. 
 
To compress your CurrentWare database: 
 

1. Make sure you have closed the CurrentWare Console.  

2. Go to the Start menu > Programs > CurrentWare > CurrentWare Server 
Manager 

3. Under the Compress tab, click on the browse button and search for your 
CurrentWare database. By default, the database is located under C:\Program 
Files\CurrentWare\cwServer\CWNPFB.CWD.  

4. Click on the Compress button to begin compressing your database.  

 

14.4 Archive and Restore the CurrentWare Database 
In order to maintain optimal database performance, it is recommended that the CurrentWare 
database be archived on a regular database.  Archiving the CurrentWare database will create a copy 
of your existing database.  However, all tracking data from the existing live database will be deleted.  
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Note: archiving will create a copy of the current database. After the archiving process is completed, 
the Internet tracking data for BrowseReporter will be deleted.  All Computer and User data will be 
maintained but the corresponding monitoring data will be removed. 
 
To Archive your CurrentWare Database: 
 

1. Under the Archive and Restore  tab, click on the Archive  button (Fig. 21). 

2. A copy of your database will be created under C:\ Program 
Files\CurrentWare\cwServer\Archive\ 

 
Restoring the database will put your current database back to the state it was prior to archiving.  The 
current database will be replaced with the archived database. It is advised that you archive your 
current database before restoring to a previous database, should you need to retrieve the original 
data.  
 
Restoring an Archived Database: 
 

1. Under the Archive and Restore  tab, select the database that you want to 
restore from the drop-down menu 

2. Click on the Restore button to begin the process of restoring your archived 
database. 
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15.0 CurrentWare and Terminal Server 
 
The CurrentWare Console is supported on a Windows Terminal Server. 

The CurrentWare Console for a terminal server is compatible for up to 65 concurrent connections. 

Beyond this maximum number of connection, some of the CurrentWare functionalities may not work 

properly. It is advised that you do not have more than 65 users connected to the Terminal Server 

simultaneously.  

The terminal server license is based on a per-user basis. Only one CurrentWare client can be 

installed on the terminal server computer.  
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16.0 Licensing 
 
CurrentWare Solutions are licensed on a per-computer basis for client management, while Terminal 
Server clients are licensed on a per-user basis.  
 
The evaluation copy of BrowseControl is functional on a maximum of 50 computers for 21 days.  
 
 

16.1 Register your Permanent License key   
After you have purchased BrowseControl, BrowseReporter, enPowerManager or AccessPatrol from 
CurrentWare, you will receive an email from our licensing department containing your license key 
information, which includes the following fields: 
 

1. Organization’s Name 

2. Number of Licenses 

3. License key 

 
To register your license key, follow the steps below 
 

1. Launch the CurrentWare Console 

2. Go to Help > Licensing  

3. From the Solutions drop down box, select the Solution  

4. Select the mode of license  (computers or terminal server) 

5. Copy your Organization’s  name, number of licenses and Activation Code  
from the licensing email sent to you  

6. Click on the Register Button 

7. Your CurrentWare Console has now been registered.  

8. Click on Next to manage the computers you want to apply the license keys to.  
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16.2 License Management 

Managing your CurrentWare Licenses 
 
You will need to manage your CurrentWare Licenses if you have applied your license key before 
installing your CurrentWare Clients.  
 

1. After you install your CurrentWare Clients, launch your CurrentWare Console 

2. Go to Help > Licensing  

3. Fill in the fields for the Organization name, solution, mode of license, number of 
licenses and license key 

4. Click next  

5. Now the License Computers  window will appear. This is where you assign your 
licenses to your computers.Click on the checkbox to assign a license key to 
your computer 

 

 

Manage your CurrentWare Licenses 

 
 

16.3 Managing your Terminal Server Licenses 
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The CurrentWare Console is compatible with Windows Terminal Server. The terminal server 

licensing is based on a per-user basis.  

When the terminal server license is applied, only one CurrentWare client can be connected to the 

CurrentWare Server. This CurrentWare client must be installed on the terminal server.  

CurrentWare‟s Terminal Server license is strictly for Windows 2003 and 2008 terminal server 

operating systems. Do not use terminal server license for any other Windows operating system as 

some of the functions will not be compatible on it.  

 

Applying your Terminal Server Licenses 
 

1. Launch your CurrentWare Console 

2. Go to Help > Licensing 

3. Fill in the fields for the Organization name, solution, mode of license, number of 
licenses and license key.  (For Mode of License select “Terminal Server”)  

4. Click next  

5. Now the License Computers  window will appear.  

6. Click on the checkbox to assign a license key to your Terminal Server 
computer. For Terminal server license, you will only be able to assign one 
license key to one terminal server.  

7. Click on the Manage Users  button on top right hand corner to assign your 
licenses to your users.  

8. You will only be able to assign the number of licenses to your Terminal Server 
users based on the quantity on your license agreement.  
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Manage your CurrentWare Terminal Server Licenses 
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17.0 Uninstall CurrentWare Server, Console and 

Solutions 
 

17.1 Uninstalling the CurrentWare Solutions 
 

1. Launch your CurrentWare Console 

2. If a solution is installed, you will see the uninstall option under the “Install” menu.  

3. Select Install > Uninstall BrowseControl, or Uninstall BrowseReporter, or Uninstall 
enPowerManager, or Uninstall AccessPatrol.  

4. Click Yes to uninstall the Solution from your CurrentWare Console.  

5. The CurrentWare Console will restart and the solution will be removed from the 
Console.  
 

Alternatively, a solution can be uninstalled form the Add/Remove Programs utility in the Control 
Panel. 
 

17.2 Uninstalling the CurrentWare Server and Console 
The CurrentWare Console and Server can be removed from the Control Panel.  

1. Before you uninstall the CurrentWare Server and Console, ensure that all of the 
CurrentWare Solutions are uninstalled first.  

2. Go to Start Menu and select Control Panel  

3. Under Programs, Select Uninstall a Program.  

4. Uninstall CurrentWare 
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18.0 Uninstall CurrentWare Client 
 
The CurrentWare Client can be uninstalled by two different methods: 

 Uninstall CurrentWare Client from the Console 

 Uninstall CurrentWare Client on the workstation by command line 

 Uninstall CurrentWare Client on the workstation from the Client 

Configuration Window 

18.1 Uninstall CurrentWare Client from the Console 
Follow the steps below to uninstall the CurrentWare Client remotely from the CurrentWare Console.  
 

1. Launch the CurrentWare Console 

2. Right click on the computer or the group of computers that you want to uninstall, 
select Client Service > Uninstall  

3. The client will proceed to uninstall  

4. A reboot will be prompted. It is recommended to restart the computer.  
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18.2 Uninstall CurrentWare Client on the workstation by 
command line 
 
Follow the steps below to uninstall the CurrentWare Client locally on the workstation by running a 
command line.  
 
You need to have your CurrentWare Client password in order to uninstall the CurrentWare Client by 
Command line.  
 

On your CurrentWare Client computer, go to start menu > run > type in the following (for Windows 7, 

go to the run command box): 

 

Cwclient –p Admin –u 

 
*The word “Admin” in the command is the password field. Admin is the default CurrentWare Client 

password. If you changed the CurrentWare Client password during the installation, please replace 

Admin with your CurrentWare Client password.   

 

18.3 Uninstall CurrentWare Client on the workstation from 
the Client Configuration Window 
 
Follow the steps below to uninstall the CurrentWare Client locally on the workstation from the 
CurrentWare client configuration Window.  
 
To bring up the CurrentWare client configuration Window, go to start menu > run > type in the 
following (for Windows 7, go to the run command box): 
 
  

Cwclient –p Admin –v 

 
*The word “Admin” in the command is the password field. Admin is the default CurrentWare Client 

password. If you changed the CurrentWare Client password during the installation, please replace 

Admin with your CurrentWare Client password.   

In the CurrentWare Client Configuration Window, click on the General Settings tab. Click on the 

Uninstall button to uninstall the CurrentWare client from your workstation.  
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19.0 Technical Support 
 
For technical support of CurrentWare, please contact us at info@currentware.com. 
 

 

  

mailto:info@currentware.com
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20.0 Contacts 
 
 

EUROPE 
Codework Limited  

Lansdowne House, 85 Buxton Rd, Stockport, SK2 6LR, United Kingdom 

Tel: +44-(0) 161 - 474 - 0444 

Fax: +44-(0) 333 - 666 - 0998  

Email: info@codework.com  

 

USA 
CurrentWare (a division of Codework Inc.)  

1623, Military Rd #556, Niagara Falls, NY 14304-1745, United States of America 

Tel: 613-368-4300  

Fax: 866-929-9808  

Email: info@currentware.com 

 

CANADA 
CurrentWare (a division of Codework Inc.)  

55 Hawktree Ridge, Ottawa, K2J 5N7, Canada 

Tel: 613-368-4300 

Fax: 866-929-9808 

Email: info@currentware.com 

 

ASIA 
Codework Solutions Pvt Ltd,  

„Thapasya‟, Infopark, Kakkanad, Kochi, Kerala, India – 682030 

Tel:  +91-484-4055678  

Fax: +91-484-4061003  

Email: info@codework.com 

 

OTHER COUNTRIES 
Please email info@currentware.com for the name of a local reseller in your country. 
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